Основные команды Cisco

Материал из darklurker wiki
Перейти к: навигация, поиск

Общие

enable //перейти в привилегированный режим
show running-config //показать текущую (запущенную) конфигурацию
show startup-config //показать как устройство будет работать после перезагрузки
hosname switch	//изменить имя хоста на switch
configure terminal //перейти в режим конфигурации оборудования
interface fastethernet 0/0 //перейти к настройке интерфейса fast ethernet 0/0
interface range fastethernet 0/0 - 3 //перейти к настройке пачки интерфейсов от 0/0 до 0/3
shutdown // выключить интерфейс (no shutdown  включить интерфейс)
ip address 192.168.0.1 255.255.255.0 //установить ip адрес на интерфейс
ip address dhcp //получить ip адрес на интерфейс по DHCP
ip route 192.168.30.0 255.255.255.0 192.168.20.50 //прописать маршрут
ip name-server 192.168.0.1 //прописать dns сервер
no service config //убрать аля «Error opening tftp://255.255.255.255/networkconfg (Timed out)» нужен ребут
cdp timer 5 //изменение частоты отправки пакетов CDP (в секундах)
cdp holdtime 10 //через сколько секунд признавать соседа недоступным
no ip cef //глобальное отключение механизма Cisco Express Forwarding (на всех интерфейсах)
no ip route-cache cef //отключение механизма Cisco Express Forwarding на интерфейсе
service compress-config	//сжимать running-config при каждом его сохранении в nvram
ip proxy-arp //включить технологию Proxy ARP
configure replace nvram:startup-config //поместить содержимое startup-config в running config. В этом случае, содержимое текущего running config полностью заменится содержимым startup-config. При использовании команды copy, данные из файла startup-config будут добавляться к running-config
end //выйти из режима конфигурирования
show ip interface fastethernet 0/0 //показать конфигурацию интерфейса  с точки зрения сетевого уровня (ip)
show interface fastethernet 0/0 //показать конфигурацию интерфейса с точки зрения канального уровня
show interface status //показать статусы всех портов свитча
show ip interface brief	//показать все интерфейсы и их ip адреса
show cdp neighbors //показать информацию о соседнем оборудовании по протоколу cdp
show ip route //показать таблицу маршрутизации
show ip arp //показать таблицу соответствия ip и MAC адресов
copy running-config startup-config (write) //сохранить рабочую конфигурацию
debug ip nat //отслеживание nat в реальном времени (может перегрузить процессор)
show logging //показать последние события
terminal monitor //передавать все сообщение из консоли (например дебаг) в telnet или ssh
show errdisable recovery //посмотреть порты, которые находятся в состоянии errdisable
ip name-server 192.168.1.1 //задать ip DNS сервера
show control-plane host open-ports //показать открытые порты на устройстве
show processes cpu //показать загрузку CPU
logging synchronous //по умолчанию журнальные сообщения могут выводиться в независимости от того набирает пользователь какие либо команды или нет, прерывая исполнение текущих команд.  Включая эту команду, маршрутизатор начинает дожидаться завершения текущей команды и вывода ее отчета.
show mac address-table int fa0/1 //показать MAC адреса за интерфейсом fast ethernet 0/1
show ip arp //показать таблицу ARP
no switchport //перевод порта свитча в роутерный режим
show file system //показать сколько осталось flash и nvram памяти
show memory //показать сколько осталось оперативной памяти
show flash: //показать содержимое flash памяти
show license //показать лицензии, установленные на устройстве
show platform tcam utilization //показать оставшиеся ресурсы таблицы TCAM (сколько маршрутов еще можно добавить в этот L3 свитч или роутер, сколько ACL листов, сколько QoS и так далее)
show sdm prefer //посмотреть какой SDM шаблон используется (как используется память TCAM)
show lldp (cdp) //показать состояние протокола lldp или cdp (включен/выключен)
show lldp neighbords //показать соседние устройства по lldp
sdm prefer dual-ipv4-and-ipv6 default //переключить использование TCAM памяти на работу как с ipv4 так и ipv6
lldp run //включить LLDP глобально
lldp enable //включить LLDP на интерфейсе
no cdp run //выключить CDP глобально
copy startup-config ftp://user:pass@host/path/name.txt //скопировать startup-config на ftp
copy ftp://user:pass@host/path/name.txt startup-config //обратная операция, скопировать конфигурацию из файла и поместить её в startup-config


Конфигурация EIGRP

Конфигурация

router eigrp 1 //перейти в контекст настройки eigrp
no auto-summary //перевести EIGRP в бесклассовый режим (работа по маскам) + отключить автоматическое суммирование маршрутов
network 192.168.1.0 0.0.0.255	//анонсировать сеть 192.168.1.0 0.0.0.255 всем другим участникам
network 192.168.2.0 0.0.0.255 //анонсировать сеть 192.168.2.0 0.0.0.255 всем другим участникам
int fa0/0 //перейти к редактированию интерфейса fast ethernet 0/0
ip hellow-interval eigrp 1 10  //посылать hellow пакеты каждые 10 секунд
ip hold-timer eigrp 1 30 //признать соседа недействительным, если мы от него не получили hellow пакеты в течении 30 секунд
router eigrp 1	//перейти в контекст настройки eigrp
eigrp 1 stub  [connected | receive-only | redistributed | static | summary] //получать все маршруты, но анонсировать только коннектед-сетки и суммированные маршруты (можно указать и другие параметры, например не анонсировать вообще никакие маршруты, а получать все) 
debug eigrp //включение вывода информации о процессах eigrp для его отладки (после просмотра дебага - undebug all)
ip summary-address eigrp 1 10.64.0.0/14 //анонсировать по интерфейсу суммированный маршрут
metric weights <TOS> <K1>  <K2>  <K3>  <K4>  <K5> //изменение K-коэффициентов. У каждого коэффициента диапазон значений от 0 до 255. TOS — Type Of Service. Диапазон значений от 0 до 8. Поддерживается только значение 0.
metric maximum-hops <1-255> //изменение max-hop. По умолчанию у EIGRP значение maximum-hops равно 100. То есть, маршрут, который достижим через 100 hop'ов считается недостижимым.
traffic-share balanced	//без дополнительных настроек с помощью команды traffic-share, EIGRP балансирует нагрузку между маршрутами независимо от метрики. Включение балансировки по принципу, чем меньше метрика маршрута, тем больше передается по нему трафика (обратно пропорционально метрике)
traffic-share min //несмотря на то, что есть несколько маршрутов, отправлять трафик только по маршрутам с наименьшей метрикой
variance 2 //включение балансировки между маршрутами с разной метрикой. Значение variance может быть от 1 до 128. Это множитель, указывающий во сколько раз основной маршрут будет лучше, чем feasible successor. В этом примере, если feasible successor будет не дороже, чем в 2 раза по сравнению с основным маршрутом successor, то он будет использоваться для балансировки трафика. 
maximum-paths 6	//изменение количества маршрутов с одинаковой метрикой, между которыми выполняется балансировка нагрузки. Для того чтобы отключить балансировку нагрузки, надо установить количество маршрутов равным 1
neighbor 192.168.2.0 //вручную прописать соседа (используется в NBMA сетях)
no ip split-horizon eigrp 100 //отключение функции split-horizon на интерфейсе

Команды в PDF файле

Медиа:Cisco.pdf